Power Outage

Major incident Ontario Offices Kitchener
2024-05-01 11:01 MDT · 2 hours, 44 minutes

Updates

Resolved

Power has been restored now.

May 1, 2024 · 13:45 MDT
Issue

There is currently an unplanned power outage in our Kitchener Office. The vendor has provided an estimate of the time to restore power. The power is expected to return at 3:30 pm local time. Corporate IT is monitoring the situation.

During the outage, users will be unable to work in the office or access remote desktops in the office using Parallels.

VPN users should be able to work from home normally.

May 1, 2024 · 11:01 MDT

← Back