Power Outage Regina Office

Major incident Saskatchewan and Manitoba Offices Regina
2024-05-29 07:33 MDT · 2 hours, 37 minutes

Updates

Resolved

Power has been restored to the Regina office.

May 29, 2024 · 10:08 MDT
Monitoring

SaskPower has resolved the issue, we are just bringing up the services and will be monitoring.

May 29, 2024 · 09:49 MDT
Issue

There is currently an unplanned power outage at the Regina office. SaskPower has not provided an estimate of the time to restore power. Corporate IT is monitoring the situation.

During the outage, users will be unable to work in the office or access remote desktops in the office using Parallels.

VPN users should be able to work from home normally.

May 29, 2024 · 07:33 MDT

← Back