Power Outage in Vernon Office

Minor incident BC and Northern Offices Vernon
2024-06-26 14:45 MDT · 16 hours, 43 minutes

Updates

Resolved

The power is back on in the Vernon office.

June 27, 2024 · 07:27 MDT
Issue

The power is out in the Vernon office as of about 1:40 PM local time today. So far there is no indication from the power company about the estimated time of restoration. No IT services will be available in the Vernon office until power is restored.

June 26, 2024 · 14:45 MDT

← Back