Service Desk Not Responding
Minor incident
Major Applications
Service Desk
2024-11-17 19:26 MST
· 21 hours, 59 minutes
Updates
Monitoring
November 18, 2024 · 07:00 MST
The ServiceDesk has been repaired, monitoring for a short time to ensure performance meets minimum standards.
Issue
November 17, 2024 · 19:26 MST
The Service Desk at servicedesk.ae.ca is not responding. Corporate IT is aware of the issue and is troubleshooting. If you have urgent support needs please contact your most local IT support person directly on Teams.
← Back