Power Outage Victoria Office

Minor incident BC and Northern Offices Victoria
2025-02-25 07:19 MST · 2 hours, 47 minutes

Updates

Resolved

The power issue has been resolved in our Victoria Office.

February 25, 2025 · 10:06 MST
Issue

There is currently an unplanned power outage at our Victoria Office. BC Hydro hasn’t provided an estimate of the time it will take to restore power. Corporate IT is monitoring the situation.

During the outage, users will be unable to work in the office or access remote desktops in the office using Parallels.

VPN users should be able to work from home normally.
.

February 25, 2025 · 07:19 MST

← Back