Phish Alert Button Not Working

Minor incident Major Applications Email (Exchange Online)
2025-03-14 14:08 MDT · 2 days, 20 hours, 30 minutes

Updates

Resolved

Logging shows that the updated authentication methods are working as expected.

March 17, 2025 · 10:38 MDT
Issue

Microsoft has updated the way that Phish Alert logs into Exchange Online. The Phish Alert button is currently not working because of this update, and if you try to use it you may receive a message stating the application token is no longer valid.

There is an updated authentication mechanism available, and Corporate IT has reconfigured the Phish Alert button to use the updated mechanism, but it may take several hours for the changes to become completely effective.

Phish Alert should be fully restored to normal functionality in the next few hours.

March 14, 2025 · 14:08 MDT

← Back