Power Outage Prince Albert Office

Minor incident Saskatchewan and Manitoba Offices Prince Albert
2025-04-11 10:38 MDT · 48 minutes

Updates

Resolved

Power has been restored to the office.

April 11, 2025 · 11:26 MDT
Issue

There is currently an unplanned power outage at our Prince Albert Office. SaskPower has dispatched repair crews, there is no estimated time for repairs.

During the outage, users will be unable to work in the office or access remote desktops in the office using Parallels.

VPN users should be able to work from home normally.

April 11, 2025 · 10:58 MDT

← Back