Saskatoon Office Internet Connection Outage (ISP related)

Minor incident Saskatchewan and Manitoba Offices Saskatoon
2025-06-05 08:07 MDT · 1 day, 1 hour, 34 minutes

Updates

Resolved

Issue has been resolved.

June 6, 2025 · 09:42 MDT
Monitoring

SaskTel has restored the Internet Service.

Corporate IT is monitoring the situation.

June 5, 2025 · 08:07 MDT

← Back