Power Outage Red Deer Office

Minor incident Alberta Offices Red Deer
2025-07-02 11:59 MDT · 1 day, 20 hours, 24 minutes

Updates

Resolved

Issue has been resolved.

July 4, 2025 · 08:23 MDT
Monitoring

Power has been restored in our Red Deer Office

July 2, 2025 · 13:28 MDT
Issue

There is currently an unplanned power outage at Red Deer. Currently there is no estimate of the time when the power will be restored. Corporate IT is monitoring the situation.

During the outage, users will be unable to work in the office or access remote desktops in the office using Parallels.

VPN users should be able to work from home normally.

July 2, 2025 · 11:59 MDT

← Back