Internet Connection outage

Minor incident Alberta Offices Red Deer
2025-07-15 07:46 MDT · 5 hours, 51 minutes

Updates

Resolved

Issue has been resolved.

July 15, 2025 · 13:37 MDT
Issue

There is currently an unplanned internet service outage at Red Deer Office. We currently don’t have an ETA when the service will be back up. (this outage could be due to power outage. Corporate IT is monitoring the situation.

July 15, 2025 · 07:46 MDT

← Back