Autodesk Construction Cloud down due to global Amazon Web Service outage.
Major incident
Major Applications
Autodesk Cloud Services
2025-10-20 08:00 MDT
· 1 day, 54 minutes
Updates
Resolved
October 21, 2025 · 08:53 MDT
All issues impacting AutoDesk Construction Cloud have been resolved.
Update
October 20, 2025 · 16:58 MDT
ACC is still experiencing a widespread outage due to a major service disruption at Amazon Web Services (AWS), which hosts Autodesk’s cloud infrastructure.
What we know so far:
• The issue is linked to a significant outage in AWS’s US-EAST-1 region, impacting multiple global services.
• Autodesk is actively working with AWS and providing hourly updates on their Autodesk Heath Dashboard
Issue
October 20, 2025 · 08:45 MDT
Amazon is currently suffering a global outage in their web services. This affects many other service providers’ offerings. In our case Autodesk Construction Cloud is unavailable. The production Services group is working on a workaround.
← Back
Associated Engineering IT Service Status