ServiceDesk is currently unavailble.

Minor incident Major Applications Service Desk
2025-10-27 16:47 MDT · 15 hours, 31 minutes

Updates

Resolved

The ServiceDesk system has been returned to normal functionality.

October 28, 2025 · 08:18 MDT
Monitoring

The ServiceDesk is now available, we will keep on monitoring if the issue happens again.

October 27, 2025 · 17:54 MDT
Issue

The ServiceDesk is currently experiencing problems. Users can’t submit tickets via the web interface and support technicians can’t login and pickup tickets. The problem is being worked on.

If you need to make a ticket and the problem is not immediate, please submit the ticket by sending an email to servicedesk@ae.ca, and the ticket will get created automatically when the system resumes normal operation.

If you have an urgent issue, please contact one of our support technicians on Teams.

October 27, 2025 · 16:47 MDT

← Back