Power outage in Winnipeg Office
Major incident
Saskatchewan and Manitoba Offices
Winnipeg
2025-11-24 09:31 MST
· 4 hours, 29 minutes
Updates
Post-mortem
November 24, 2025 · 14:28 MST
The power company in Winnipeg has resolved the power issue.
Issue
November 24, 2025 · 09:51 MST
There is a power outage affecting the Winnipeg office, starting at about 10:30 today. Manitoba Hydro expects to have it repaired by 2 PM local time.
← Back
Associated Engineering IT Service Status