Power outage in Winnipeg Office

Minor incident Saskatchewan and Manitoba Offices Winnipeg
2025-12-04 09:16 MST · 2 hours, 25 minutes

Updates

Resolved

The power utility has restored power to the area. Systems are back up and running.

December 4, 2025 · 11:18 MST
Issue

The power is out at the Winnipeg office. It is a utility outage. The hydro company has not yet posted an estimated time of repair.

December 4, 2025 · 09:16 MST

← Back