Vision and iAccess Incident.

Minor incident Major Applications Vision and iAccess
2026-01-21 08:10 MST · 6 hours, 1 minute

Updates

Resolved

Issue has been resolved.

January 21, 2026 · 14:11 MST
Monitoring

Vision and iAccess services have been restored.

January 21, 2026 · 09:35 MST
Issue

There is currently a service outage of Vision and iAccess. Corporate IT is working to resolve the issue. There is currently no estimate for the repair of the service. During the outage, users will be unable to use Vision and iAccess.

January 21, 2026 · 08:10 MST

← Back