Internet Service Outage in Winnipeg

Minor incident Saskatchewan and Manitoba Offices Winnipeg
2026-02-27 10:00 MST · 51 minutes

Updates

Resolved

All services restored.

February 27, 2026 · 10:51 MST
Monitoring

Shaw has restored service, we are just validating everything.

February 27, 2026 · 10:33 MST
Issue

Internet provider outage, investigating.

February 27, 2026 · 10:30 MST

← Back