Teams - External Calling

Minor incident Major Applications Teams
2026-04-16 09:33 MDT · 1 hour, 51 minutes

Updates

Resolved

The issue has been resolved.

April 16, 2026 · 11:24 MDT
Update

Fix has been implemented, initial testing shows the service is restored. Monitoring for 1hr for stability.

April 16, 2026 · 09:59 MDT
Issue

Microsoft Teams customers may currently experience issues with external calls failing. This is a known Microsoft issue, and we are actively working with them toward a resolution.

Teams to Teams calls are unaffected.

April 16, 2026 · 09:48 MDT

← Back