Saskatoon - Power Outage

Major incident Saskatchewan and Manitoba Offices Saskatoon
2026-06-02 12:17 MDT · 2 hours, 3 minutes

Updates

Resolved

Power has been restored at the Saskatoon Office.

June 2, 2026 · 14:19 MDT
Issue

There is an unplanned power outage impacting the Saskatoon office. All services currently down, no ETA has been provided.

June 2, 2026 · 12:42 MDT

← Back