Whitehorse Power Outage

Minor incident BC and Northern Offices Whitehorse
2026-07-20 13:11 MDT · 20 hours, 28 minutes

Updates

Resolved

The issue has been resolved.

July 21, 2026 · 09:40 MDT
Monitoring

Power has been restored; Corporate IT is monitoring the situation.

July 20, 2026 · 14:35 MDT
Monitoring

Power has been restored in our Whitehorse office. Corporate IT is monitoring the situation.

July 20, 2026 · 14:33 MDT
Issue

There is currently an unplanned power outage at the Whitehorse Office. The vendor <has | has not> provided an estimate of the time to restore power. There is no ETA for when the power will return. Corporate IT is monitoring the situation.

During the outage, users will be unable to work in the office or access remote desktops in the office using Parallels.

VPN users should be able to work from home normally.

July 20, 2026 · 13:11 MDT

← Back