Microsoft 365 Service Interruption

Minor incident Major Applications OneDrive and SharePoint Teams
2026-07-23 09:00 MDT · 7 hours, 54 minutes

Updates

Resolved

Microsoft has resolved the issue.

July 23, 2026 · 16:54 MDT
Monitoring

Jul 23, 2026, 12:36 PM MDT
We’ve confirmed that our networking change reversion has completed, and our telemetry indicates that our service has recovered following this action. We’re closely monitoring our telemetry and reaching out to sample affected users to validate resolution while we evaluate what other actions may be needed.

July 23, 2026 · 13:15 MDT
Issue

Issues accessing or using Microsoft 365 services in the North America region.

Issue ID: MO1437424
Affected services: Microsoft 365 Copilot Chat, Microsoft 365 suite, Microsoft OneDrive, Microsoft Power Automate in Microsoft 365, Microsoft Teams, SharePoint Online
Status: Service degradation
Issue type: Incident
Start time: Jul 23, 2026, 9:06 AM MDT

User impact
Users may be experiencing issues accessing or using Microsoft 365 services in the North America region.

More info
We’ve confirmed that multiple Microsoft 365 services are degraded, including but not limited to:
-Microsoft OneDrive - Access to OneDrive is intermittent.
-SharePoint Online - Error message, “Something went wrong”
-Microsoft Teams - Degraded chat functionality, including images not loading.
-Microsoft 365 Admin Center - Admin Center is loading slowly or not at all.
-Power Automate - Automate flows not loading.
-Copilot Chat - Intermittent delays or failures in any Copilot Chat action and query.
-Microsoft Loop - Unable to open or load Loop pages.

Scope of impact
Users accessing Microsoft 365 services through affected network paths in the North America region may be impacted, though users located or served from other regions may also experience impact.

Current status
Jul 23, 2026, 11:04 AM MDT
We’re scaling traffic rerouting efforts up across our service infrastructure and are seeing indications of increasing relief in our telemetry. We’re implementing additional mitigation measures alongside these actions to improve service availability and expedite resolution for affected users.

July 23, 2026 · 11:37 MDT

← Back