Slow Logins and Errors in Dynamics

Minor incident Major Applications Dynamics
2026-08-20 08:36 MDT · 4 days, 23 hours, 3 minutes

Updates

Resolved

AX1458246: Users experienced intermittent degraded performance and timeouts when accessing your environment

Users experienced intermittent degraded performance and timeouts when accessing your environment

User impact: Users experienced intermittent degraded performance and timeouts when accessing your environment.

More info: This issue only affected environments with Dataverse integration.

Final Status: We identified disabled nodes within a service dependency as the source of the impact. To mitigate the issue, we performed a scale-out operation to increase node availability within the dependency and, following a period of service health diagnostic analysis, we confirmed that service functionality is restored.

This is the final update on the incident.

Preliminary Root Cause: Disabled nodes within a service dependency.

Next Steps: We’re reviewing our code for improved performance and potential automated recovery options to reduce or avoid similar issues in the future.

August 20, 2026 · 17:00 MDT
Issue

Dynamics Project Operations, Customer Engagement, and Finance and Operations are experiencing issues. Users may see slow logins and errors indicating too many connections. This issue is affecting multiple organizations. Microsoft is aware and working on the problem. There is currently no estimated time to repair.

August 20, 2026 · 08:36 MDT

← Back